iTunes reports "Error -19" when I try to upgrade to iPhone OS 2.0.1, what can I do?

iTunes reports "Error -19" when I try to upgrade to iPhone OS 2.0.1, what can I do?

Many users have found themselves unable to upgrade their iPhones to OS 2.0.1 (bugfix release) because of an unspecified error. In several cases, there is a workaround to avoid this issue.

Please refer to this article for more information.

Comments

Add new comment